Whenever I load a game it says "citra-qt.exe has stopped working."

Issue:
Enter a description of your issue here, in full detail. When I’m trying to run Persona Q2 or super mario 3d land it says citra has stopped working. Whenever I disable the hardware renderer, the game ends up loading but it runs at only 2-3%.

System Information

  • Operating System: Windows 8.1
  • CPU: Intel® Core™ i7-4700MQ CPU @ 2.40GHz
  • GPU: Intel® HD Graphics 4600
  • Citra Version (found in title bar): Citra Canary latest version
  • Game: Persona Q2: New Cinema Labyrinth & Super Mario 3D Land
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (18.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log gets cleared each time you open Citra so make sure you just have the log folder in the background for easy access to the log file then make Citra crash, after that you can upload the log(and do not reopen Citra or you have to do this again).

citra_log.txt (13.5 KB)

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I followed the exact steps for uploading the log, but I’m still getting the same results where everything is showing up as “null.”

As I mentioned before, citra only successfully runs when I disable the hardware renderer but it runs at 2-3%. The log I have attached before was from when citra would crash upon the loading of the game. I will now attach a log of when citra successfully runs while the hardware rendererer is disabled. citra_log.txt (24.8 KB)

System Information for Support

OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4600
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.10.3277
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

Ah I see, I will keep that in mind in the future that they should upload a log with Hardware Renderer disabled, since we got a useful log now.

Ow those drivers are very old, from 2013.

Download win64_15.36.37.5074.zip from https://downloadcenter.intel.com/download/29197/Intel-Graphics-Driver-for-Windows-7-8-1-15-36-?product=75117
direct link: https://downloadmirror.intel.com/29197/a08/win64_15.36.37.5074.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Intel HD 4600 is also a problematic GPU that relied on the “AMD hack” for some games which was last seen on Nightly-860 where it was applied for all GPUs.

1 Like

I managed to update the drivers. After updating the drivers, the game runs very well, but when I play in full screen with one screen being displayed the game will crash after 7-10 minutes of playtime. When I play in full screen with both screens being displayed side by side I had uninterrupted gameplay (I managed to play for half an hour before trying a different display). I also had uninterrupted gameplay with playing both screens side by side in non full screen mode. Here are some screenshots from the crash:

Also here is the log from that playsession: citra_log.txt (46.6 KB) I was wondering what the problem was and why it still crashes sometimes.

System Information for Support

OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4600
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.14.5074
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4600
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.14.5074
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

Yeah this is probably the Intel drivers crashing bug I managed to reproduce in Kid Icarus: Uprising a couple of weeks ago on Intel HD 4000.

You could try an older build like Nightly 1390 and see if it still crashes.

mine also has the same problem when i load pkmn x or other games it stops working but when i disabel hardware shader the game works but very slow. i thought that it was because of my opengl version but when i checked it using opengl extensions viewer i have opengl version 4 my graphic card has Intel HD Graphics Family. I played in 2018 and it was pkmn ultra moon at 20 fps but now i cant work even the old citra and new citra.Here is the log filecitra_log.txt (72.4 KB)

System Information for Support

Client Version                                Canary 1627 HEAD-4a03207
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4400
OpenGL Version                                3.3.0
GPU Driver Version                            9.18.10.3186
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.