Windows 11_Citra Nightly 1823_Audio lag plus low fps

Issue:
The audio is super lag when in open world, with super low fps below 20.

citra_log.txt.old.txt (748.3 KB)

System Information

  • Operating System: Windows 11, 64 bit
  • CPU: 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 1.69 GHz
  • GPU: Intel Iris Xe
  • Citra Version (found in title bar): Nightly 1823
  • Game: Pokemon X

Thanks in advance.

What do you mean when you say “Audio lag”? If its when you open something outside the emulator then go back on to the emulator and it resumes but lags behind, turn off audio stretching. If its making the game run very slow, change it to fast, since accurate is for debugging only.


My apologies for being confusing, I means when my character is walking around the open world as per attached photo my Citra is experiencing lags as well as very low fps. The lags happens whenever I’m moving around menu, talking to NPC, checking Pokemon info etc…
I’ve tried turning on and off audio stretching as you’d mentioned but it didn’t help. Meanwhile the emulation audio speed is at fast by default.

I notice that Citra Bot hasn’t read your log file, try reuploading to to try get it to read it, since Citra Bot can troubleshoot most problems

We’re in the process of switching some stuff in the server’s backend, specifically file hosting. However, discourse didn’t account for our use-case, which has now caused some problems with accessing certain files. The bot, whilst active, can’t access the log files at the moment. We’re hoping to resolve this sometime soon.

If you look around, none of the recent posts have gotten replies back from the bot about their log files.

I’m not seeing anything wrong with your settings in the log file. I’m suspecting this may have to do with your GPU driver, as you’re one of the few people with a G-series Intel iGPU. We haven’t had too much testing from that yet.

So, in order to confirm this, I’d like you to try out an older Citra build:
Download citra-windows-mingw-20220901-d380980.7z from Release nightly-1782 · citra-emu/citra-nightly · GitHub
Extract it using Winrar or 7zip, then launch citra-qt(.exe) from the extracted nightly-mingw folder. Now try your game again and see if the issue remains.

citra_log.txt nightly 1782.old.txt (34.7 KB)
citra_log.txt nightly 1714.old.txt (35.2 KB)

I’ve tried version 1782 and also randomly picked one older version of 1714, but the problem remains.
Attached log files for your reference.
Meanwhile I’ve noticed something that the fps is normal (50+) before I select character to enter the game, and after entered the game the fps dropped significantly to 17 and below.

Hmmm, maybe I missed something else in the log file. Start up the latest Nightly build and go to Emulation>Configuration>General and select Reset All Settings.

I’ve done resetting on the latest nightly yet nothing has changed.
citra_log.txt.old.txt (45.6 KB)

Thanks for explaining that, i wasn’t sure why the bot wasnt reading the file, that makes sense now :slight_smile:

I have a similar issue with Yo-Kai watch 3 for the phone port, where if i scan for Yo-Kai with the watch, the fps drops from 30 to around 8. Im not sure if any of the settings effect this issue