Won't go further than title screen, all specs are met

Issue:
Once I proceed from this screen, it won’t progress and I will have speed 0-3%. The screen will become completely unresponsive. It does this even when I start a new save file or a completely different pokemon game.

I have all the right requirements for Mac, which is openGL 3.3 and 64 bit. I have played around with Citra emulation settings such as enabled and disabled renderer, on the lowest graphic, etc. Have tried switching to nightly, no change. How do I fix this?

System Information

  • Operating System: macOS High Sierra – 10.13.6
  • CPU: Intel Core i5
  • GPU: Intel HD Graphics 3000
  • Citra Version (found in title bar): Canary 1787
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (63.9 KB)

System Information for Support

Client Version                                Canary 1787 HEAD-408778a
Operating System                              macOS High Sierra (10.13)
CPU                                                  Intel(R) Core(TM) i5-2435M CPU @ 2.40GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             Intel HD Graphics 3000 OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 2
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Enable Hardware Renderer in the Advanced graphics options. Even I get ~1fps if I turn it off on an i7-3770K @ 4.3GHz with GTX 1070 :stuck_out_tongue:

Thanks for responding. Again, as I say, I’ve tried playing around with everything. The log showed above was just one example, but i’ve tried every case, with it render ON or OFF or combined it with other settings on and off.

I would try redump the game using the guides below to make sure it is clean, have at least 4GB free space on your Nintendo 3DS’s SD card before you dump:


Intel HD 3000 barely supports OpenGL 3.3 on macOS and Linux (on Windows it only goes up to 3.1) so it could be a factor.

Now that you say it, I’m certain this is a problem of my GPU, because before I had a different laptop which was Windows, and it ran every game fine. I do not think re-dumping will solve it because this is happening for every game.

Well I’m not very pro on Mac, so do you know if my gpu can be upgraded by any chance?

Never mind seems as you can’t. I would have to get an external GPU.
Well, thanks for the exchange, I really appreciate it.

Yeah, laptops have integrated parts so you really can’t “upgrade”. It’s almost exclusively RAM and storage where you can.

Just a bit of a warning though, Apple has deprecated OpenGL and their next set of iMacs, MacBooks etc. will run on their own ARM processors so Citra won’t be compatible at all anymore. macOS 10.15 Catalina will be the last that use x86.

You can watch the announcement here:

This is irrelevant if your next buy is a gaming PC or whatever :stuck_out_tongue:

ugh, that’s really annoying…

Is there any way to transfer my save file to a different emulator? I cannot redump the game, I have the rom, but can a different emulator be used for my current save file?

You can access your save file by right clicking on the game in Citra (assuming you have added a game folder) then pick Open Save Data Location then copy all the files there. Some games also use extra data so repeat the process but with Open Extra Data Location instead.

The only Nintendo 3DS emulators that exist are Citra and Mikage (still in alpha), regular game saves should work on any of them since emulators mimics the hardware. If you have Android you can test Citra on it, minimum specs are 64-bit Android 8 (Oreo) and GLES 3.1 support.