Xenoblade Chronicles 2 Graphic Glitch

Hey, I’ve been trying to play XBC 2 for a few days now but I keep getting this graphic glitch. Sometimes it goes away after a few minutes in a certain area but there are always objects that still have it, restarting the game sometimes helps aswell, but for whatever reason there are certain areas where it just won’t go away until I switch OpenGl and Vulkan and restart a couple of times. But this glitch always reappears when I’m quick travelling back and forth and it’s quite annoying. I tested out the newest and some older drivers, different versions of yuzu, turning on and off different settings, increasing my pagefile to 25gb, playing with and without update and dlc, deleting my shader cache. I did also reset my Windows 10 and installed everything again, and installed Linux to test it aswell. It happens on both Vulkan and OpenGL except on OpenGL on Windows but I only get 10-15 fps because of amd. I’m not sure if I’m allowed to mention this but I don’t get this graphic glitch on another emulator I tried out, however the performance is too bad for me on that one. My specs are : GPU: RX 580 8gb, CPU: i7-6700 and 8gb ram.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

yuzu_log.txt (687.0 KB)

System Information for Support

Client Version                                yuzu Development Build HEAD-mainline-636-6758-gd8a168962-dirty
Operating System                              Manjaro Linux
CPU                                           Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz | AVX2 | FMA
RAM                                           7.72 GB
Pagefile / Swap                               0.00 GB
Graphics API                                  OpenGL 4.6
Graphics Renderer                             Radeon RX 580 Series (POLARIS10, DRM 3.42.0, 5.14.0-1-MANJARO, LLVM 12.0.1)
GPU Driver Version                            Mesa 21.1.5
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [ ]
Async Shaders                                 [ ]
CPU Accuracy                                  Debug
GPU Accuracy                                  High

Here’s some issues I found with your log that might help.

  • Enabling Async GPU emulation is recommended as it can improve the performance of many games.

Set CPU accuracy to auto, enable asynchronous GPU emulation, and use either GLSL or Vulkan, don’t use SPIR-V.

Thanks for the reply,
I tried with these settings enabled again but unfortunately it’s still the same. On OpenGL (GLSL) this glitch sometimes fixes itself after waiting a bit or restarting the game, but it always reappears if I quick travel to different areas forcing me to restart quite a lot, and sometimes not even that helps and I have to travel to a different area, restart and get back to the area I wanted to go and hope it fixes itself this time. On Vulkan however it’s even worse, it’s permanent in every area of the game I checked. It’s the same for Vulkan on Windows only that I have even more graphic glitches cause of the windows amd driver. I’m pretty sure I went trough almost all settings on yuzu so far and I can’t think of any other options I could try out. I also have a log on linux with opengl with graphic debugging enabled if that helps.

I passed this info to our devs, hopefully we can debug it and fix it, and if it is a mesa issue, report it to them.

Thank you for the reply and your time. If you need any more info or logs let me know.

No graphic glitches for Nividia.



same issue here for vulkan using amd graphic card