Xenoblade Chronicles 2 Torna DLC game freezing

After finishing Xenoblade Chronicles 2 I’m playing the Torna - The Golden Country DLC and I’m pretty sure I’m at the end of the DLC. After 21 hour of playtime I’m running around doing side quests and had almost no issues, just some cloud flickering and some crazy poligons here and there that could be solved by reloading the game.
After a couple days of not playing, today I downloaded the new version of Yuzu (1419), updated the firmware and keys and suddenly during battle the game just freezes.
On my last try, the music kept playing but the game was stuck and the time before i could just hear the ambience wind sound. I also updated my video card drivers just in case but it still happens.
I haven’t tried the base game to check if it happens there too.
I have a RTX 3080 and an Intel i7-12700KF processor. The game is patched in Yuzu to 2.1.0 with all 7 DLCs (1, 2, 3, 4, 5, 6, 99) and I’m playing at CPU High with Vulkan rendering (OpenGL stutters a lot)
Here are the logs from the last 2 times the game froze.
yuzu_log1.txt (964.3 KB)
yuzu_log2.txt (1003.2 KB)


It happens with the base game too. The game would freeze during battle or after a cutscene. The version I’m using is yuzu 1420 and the game is patched to 2.1.0.

AMD Ryzen 5 5600X 6-Core processor
NVIDIA GeFirce RTX 3070

yuzu_log.txt (664.2 KB)