Yet another std::bad alloc Victim

Issue:
Whenever I try to make a save state or load a state, I get the aforementioned message. I don’t understand, because this just SUDDENLY happened! It didn’t use to happen. I’ve read somewhere that downloading the previous version of the emulator and making a savestate there, then saving the game will fix the newer savestates. I tried downloading my previous version, 1718, but it didn’t work. It still gave the same message. Does anyone have another fix in mind?

EDIT: Now the game won’t run at all! Here’s the new log for that.
citra_log.txt (11.6 KB)

System Information

  • Operating System:
  • CPU: Intel Core i5 (8 GB)
  • GPU: Nvidia GeForce GTX 1660 Ti
  • Citra Version (found in title bar): 1719
  • Game: Puzzles and Dragons Z + Super Mario Bros. Edition
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (12.8 KB)

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-10300H CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2
GPU Driver Version                            462.80
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-10300H CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2
GPU Driver Version                            462.80
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

iirc, this error occurs mostly when loading a save states on a different Citra version than the one it was saved on. Does this same issue occur when you create a new save state and load that? Or only when you load an older save state?

I never tested making new save states and trying to load. I just know making new savestates over top of old ones throws the error, and so does trying to load old ones. In any case, I restarted my computer and the issue fixed itself.