Yuzu closes right after opening

here is the log file

[17:37:15][liftinstall][INFO] yuzu installer
[17:37:15][liftinstall][INFO] Using pre-existing metadata file: “C:\Users\markc\AppData\Local\yuzu\metadata.json”
[17:37:15][liftinstall::frontend::rest::server][INFO] Spawning server instance @ V6([::1]:49824)
[17:37:15][liftinstall::frontend::rest::server][INFO] Spawning server instance @ V4(127.0.0.1:49824)
[17:37:15][liftinstall::frontend::ui][INFO] Spawning web view instance
[17:37:15][liftinstall::frontend::js][INFO] Making HTTP request to /api/dark-mode
[17:37:15][liftinstall::frontend::js][INFO] Making HTTP request to /api/installation-status
[17:37:15][liftinstall::frontend::js][INFO] Vue started
[17:37:15][liftinstall::frontend::js][INFO] Making HTTP request to /api/config
[17:37:15][liftinstall::frontend::rest::services::config][INFO] Downloading configuration from “https://raw.githubusercontent.com/yuzu-emu/liftinstall/master/config.windows.v10.toml”…
[17:37:15][liftinstall::frontend::rest::services::config][INFO] Configuration file downloaded successfully.
[17:37:15][liftinstall::frontend::js][INFO] Making HTTP request to /api/check-auth
[17:37:15][liftinstall::frontend::rest::services::authentication][INFO] No passed in credential and no stored credentials to validate
[17:37:15][liftinstall::frontend::js][INFO] Next stop: “/install/regular/false”
[17:37:15][liftinstall::frontend::js][INFO] Installer kind: regular
[17:37:15][liftinstall::frontend::js][INFO] Installing desktop shortcut: false
[17:37:15][liftinstall::frontend::js][INFO] Making streaming HTTP request to /api/start-install
[17:37:15][liftinstall::frontend::rest::services::install][INFO] Found installDesktopShortcut “false”
[17:37:15][liftinstall::installer][INFO] Framework: Installing [“yuzu”] to “C:\Users\markc\AppData\Local\yuzu”
[17:37:15][liftinstall::installer][INFO] Framework: Uninstalling [] additionally.
[17:37:15][liftinstall::installer][INFO] Dependency tree:
InstallTask
├── Pre EnsureOnlyInstanceTask
├── Pre VerifyInstallDirTask (with clean-install = false)
└── Pre InstallPackageTask (for “yuzu”)
├── Pre DownloadPackageTask (for “yuzu”)
│ └── Pre CheckAuthorizationTask (for “yuzu”)
│ └── Pre ResolvePackageTask (for “yuzu”)
├── Pre UninstallPackageTask (for “yuzu”, optional = true)
│ ├── Pre UninstallShortcutsTask (for “yuzu”, optional = true)
│ └── Post SaveDatabaseTask
├── Post InstallShortcutsTask (for “yuzu”)
├── Post InstallDesktopShortcutTask (for “yuzu”, should_run = false)
└── Post SaveDatabaseTask
[17:37:16][liftinstall::tasks::resolver][INFO] Selected file: File { name: “yuzu-windows-msvc-20200406-72d7706c7.tar.xz”, url: “https://github.com/yuzu-emu/yuzu-mainline/releases/download/mainline-0-220/yuzu-windows-msvc-20200406-72d7706c7.tar.xz”, requires_authorization: false }
[17:37:16][liftinstall::tasks::download_pkg][INFO] “yuzu” is already up to date.
[17:37:16][liftinstall::native::natives][INFO] Generating shortcut @ “C:\Users\markc\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\yuzu.lnk”
[17:37:16][liftinstall::frontend::js][INFO] Making HTTP request to /api/exit
[17:37:16][liftinstall::installer][INFO] Shutting down installer framework…
[17:37:16][liftinstall::installer][INFO] Launching “C:\Users\markc\AppData\Local\yuzu\yuzu-windows-msvc/yuzu.exe”
[17:37:16][liftinstall::frontend::rest::services::exit][ERROR] Failed to complete framework shutdown: “Unable to start application: Os { code: 2, kind: NotFound, message: “The system cannot find the file specified.” }”

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Are you running avast or awg antiviris?

This is problem is usually caused by a false positive of your virus scanner.

You can confirm it is a false positive with an online scanner such as VirusTotal if you wish.

To fix this you’ll need to either disable or uninstall your virus scanner. Make sure to reboot if you choose to uninstall it.

Afterwards:

  1. close any yuzu / yuzu installer instances
  2. go to %localappdata% in your file browser
  3. delete the yuzu folder
  4. install yuzu with the installer from our webpage
1 Like

i am using avastn yes but it has worked up for the past few weeks and now randomly is doing this after giving me a vcruntime error which i fixed then this happened. i will try what you said thanks

you were right avast was deleting it for some reason now. i added an exception for the file and now is all set thanks so much.