Yuzu crashes when opening Configure: Option 'help-list' registered more than once!

yuzu crashes when opening configure. i tried with both mainline and compiling from source and it doesn’t work

: CommandLine Error: Option 'help-list' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
[1]    10356 IOT instruction  yuzu

In order for us to provide better support, we need to see the log generated by yuzu. This guide will walk you through how you can obtain the log file: Getting Log Files - yuzu

linux? windows?
your hardware configuration?

linux. distro is Devuan unstable (basically just debian unstable)
i have a ryzen 5 3600, 16gb ram, and a radeon rx 6600 if thats what you mean

have you tried the appimage?https://github.com/yuzu-emu/yuzu-mainline/releases/download/mainline-0-1251/yuzu-mainline-20221125-74b605547.AppImage
I personally had to switch to ubuntu after being on debian 11 because of yuzu
for the compilation, after installing all the dependencies, I managed to compile yuzu by following the tutorial, but I use the appimage which works very well

yes i tried it and it gave the same error

try with ubuntu or manjaro linux, better for gaming, driver support

im not to keen to install an entirely new distro when i can just use ryujinx. i could also try using stable, but i like having new packages

can you show the return of the command

glxinfo | grep OpenGL

lshw -C display

try install
dpkg --add-architecture i386 && sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils

Happens to me also. I am using “yuzu-mainline-20230613-4aae97d4a.AppImage” and Ubuntu 22.04.2 LTS (64 bit). My graphics card is an “AMD RX 6650 XT” but there is a catch, let me explain:

With “default” Ubuntu’s graphics drivers, Yuzu runs just fine but the performance is not that good when trying to push the game (Zelda TotK) to 60fps (both on OpenGL and Vulkan).
Therefore I have tried installing the latest amd drivers with:

dpkg -i Downloads/amdgpu-install_5.4.50406-1_all.deb
amdgpu-install --usecase=graphics,opencl --vulkan=amdvlk

after witch Yuzu crashes if I try to enter “configure” menu. The game (Zelda TotK) runs with “OPENGL GLSL” showing in the lower left corner of Yuzu but if I click it to switch to Vulkan, it crashes with the same error.

I have installed synaptic package manager and indeed there are multiple LLVM libraries installed for version 15: one came from Ubuntu and two came from amdgpu (x64 and i386).

I have tried to remove the i386 one, nothing happens, I have tried to remove the one from Ubuntu but stopped at the warning when noticed it will uninstall half of Ubuntu’s GUI like gnome and gdm3 :slightly_smiling_face:.
I have then tried to uninstall the one from amdgpu x64 and Yuzu opened the Configure menu with success… but I have stopped there and did a PC restart just out of pure curiosity … and I got the “Ubuntu gray screen of death”. Ctr+Alt+Fn to an alternative console, ran “amdgpu-uninstall” , restarted and everything booted ok (no more AMD driver graphics though)

It seems that Yuzu is confused by multiple LLVM shared libraries. Some suggested compiling your program with " -DENABLE_LLVM_SHARED=1" cmake flag as a workaround but I have not dived into the compilation process yet.

Other things to mention is that benchmarking apps work ok with lots of performance boost with the AMD drivers installed (tried Basemark and UNIGINE Superposition). My CPU is an AMD Ryzen 7 5800X3D. Also there are no log files when this happens (0 kb size).

UPDATE: I have put that flag in cmake’s generate/configure phase and it said it was ignored. I have built the project from master as of now (17 June 2023) and the resulted binary has the same behavior :confused:

UPDATE: I did it,I think I’ve manged to force my whole Ubuntu distro to use amdgpu’s LLVM x64 bit version

after amdgpu-install, I’ve made sure amdgpu’s lib files are present by running:

cat /etc/ld.so.conf.d/*

and saw two lines like “/opt/amdgpu/lib/x86_64-linux-gnu” and “/opt/amdgpu/lib/i386-linux-gnu”

first I’ve made a backup folder:

sudo mkdir /usr/lib/llvm-ubuntu

then I’ve moved the v15 x64 bit version only of ubuntu’s LLVM into the backup folder:

sudo mv /usr/lib/x86_64-linux-gnu/libLLVM-15.so /usr/lib/llvm-ubuntu/
sudo mv /usr/lib/x86_64-linux-gnu/libLLVM-15.so.1 /usr/lib/llvm-ubuntu/

Rebooted and crossed my fingers to avoid the Ubuntu’s gray screen of death and it booted fine.
If things get out of hand I will just copy back the two files from my llvm-ubuntu folder.

Yuzu works ok now, both the Config menu and VULKAN drivers.
I have some doubts regarding performance though…some areas run at about 44-50 fps - ish with my current configuration. Funny thing is that in configuration I find:

UPDATE: the solution is not ideal, perhaps Yuzu needs another compilation strategy, found some info here.
But it seems to work at normal 30fps gameplay (had to use BC3 for 8GB VRAM as advised)