Yuzu Early Access 711 crashing every 3-15 minutes in Pokemon Sword ver 1.2

Hello.
My Yuzu Early Access 711 is freezing and after several seconds it crashes every few minutes while playing Pokemon Sword or Super Mario Odyssey. I’ve tried many things already: disabling async, OpenGL, updating all drivers, downloading mods and nothing helped.
I’ve disabled cutscenes, battle effects, and scene shift but id didn’t help. I somehow managed to get to 3rd gym but it was torture having to save every minute or redo every 15 minutes of progress after crash.
My specs:
CPU: AMD Ryzen 1700x
GPU: AMD RX 580 8gb
RAM: 16 GB DDR4
MB: B450M PRO-M2
yuzu_log.txt (758.0 KB)

System Information for Support

Client Version                                yuzu Early Access 711 HEAD-1c4fc17d5
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 1700 Eight-Core Processor           | AVX2 | FMA
Graphics API                                  Vulkan 1.2.133
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            AMD proprietary driver 2.0.137
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

It still crashes in middle of fight/exploration after disabling

System Information for Support

Client Version                                yuzu Early Access 711 HEAD-1c4fc17d5
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 1700 Eight-Core Processor           | AVX2 | FMA
Graphics API                                  Vulkan 1.2.133
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            AMD proprietary driver 2.0.137
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

Can you try without multicore?

After disabling multicore i got 10 fps drop (from stable 30 to 20) and audio lags. Still crashes after few turns in battle. New log file: yuzu_log.txt (353.1 KB)

System Information for Support

Client Version                                yuzu Early Access 711 HEAD-1c4fc17d5
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 1700 Eight-Core Processor           | AVX2 | FMA
Graphics API                                  Vulkan 1.2.133
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            AMD proprietary driver 2.0.137
Use Async GPU                                 [ ]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Enabling Async GPU emulation is recommended as it can improve the performance of many games.

Could you upload me your save? It would help us debug it.

Sure:
https://drive.google.com/drive/folders/18U9JWkj7eF20pKqpBD6gkVK2Rk8N4BUd?usp=sharing

Btw I managed somehow to beat the 3rd gym and proceed to wild area with unlocked multicore and async. It crashed once after 15 mins of playing and the second time I launched game I was able to play ~50 minutes without a crash. All I did was expanding my paging file size to 25000MB - 30000MB. But Yuzu still seems to crash moment after it passes 8 or 9GB of ram usage, idk if its somehow linked to issue.

And also i tried to play without multicore, with enabled async on fullscreen. My performance dropped for about 10 fps, but it seemed playable. This time i got error “WerFault.exe: Application Error - The application was unable to start correctly” after around 10 minutes.

At that point that seems the regular vulkan crashes.
It will be painful on AMD, but can you try with OpenGL?
Thanks for the save, I’ll test with it.

Well, I somehow made it to sixth gym already so I think that i can finish story mode of this game with all those crashes. OpenGL is crashing even more than Vulkan, at least on my PC and in this game. All i can do is hope that next updates will make games more playable on AMD setup. Good luck in future updates!

1 Like

I’m having the same issue. Have you got any solution? Here is my log file
yuzu_log.txt (183.9 KB)

post your log file for support…

1 Like

System Information for Support

Client Version                                yuzu Early Access 743 HEAD-0a4ec5ee8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-9100F CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                  Vulkan 1.2.139
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            AMD proprietary driver 2.0.145
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Disable Graphics debugging and Anisotropic Filtering. Test if it happens in OpenGL.

I’ve disabled Graphics debugging and Anisotropic Filtering as you said. After ~30m it frezee again. yuzu_log.txt (1.1 MB)

zip it down… and then post it…

System Information for Support

Client Version                                yuzu Early Access 743 HEAD-0a4ec5ee8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-9100F CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                  Vulkan 1.2.139
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            AMD proprietary driver 2.0.145
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

I’m using Vulkan. Hope Vulkan will be stable for amd GPU soon