Yuzu error while initializing opengl core! NEED HELP!

#20

Vi q vc está com o mesmo problema q o meu. Conseguiu resolver?

#22

This is an English only forum, please do not post in any other language. If you are not a native English speaker and are using a translator to assist, you may write your post in your own language as long as you provide the text of the automatic translation in the post.

Please know that if you’re experiencing an OpenGL error, and you’ve updated your graphics drivers, there is no solution except to upgrade your hardware. There are no current plans to change the OpenGL requirements.

#23

Yeap! I solved it… bought a switch console x.x

#24

Direct state access. https://www.khronos.org/opengl/wiki/Direct_State_Access

Summary: different gpus have a different number of texture/buffers/etc that can be bound at any given time. If you need to draw something thats texture, need to access a buffer, need to do just about everything on a GPU, you’ll need to bind the data to the current context. But things get complicated as we are emulating a modern GPU, and this GPU will bind things, so we need to emulate their texture access/buffer access/etc with binding the objects on your GPU. As an example using fake numbers, lets say the game uses 20 bindings, but your GPU only supports 16 binding point. What do you do? Well… you just don’t support that GPU. But theres another way to support that GPU, you can use dsa to do bindless modifications to things. DSA lets you access and modify things without binding it.

Not likely, and no.

No, citra’s openGL requirements have only gone up over time, not down. It originally was openGL 3.1, but changed to 3.3 when we needed to add host geometry shaders for perspective correction.

No. You can either buy a new gpu that supports dsa or just live without playing games on yuzu. As an emulator for a modern console, you should not expect gpu hardware thats older than the switch to be able to play switch games.

#25

my opengl version is 4.4 and you guys were saying yuzu need at least 4.3 so why am I not able to play any games in yuzu

#26

You need at least 4.3 AND support for the ARB_direct_state_access extension. Since you have 4.4, then it must be that your GPU doesn’t support ARB_direct_state_access.

#27

then how to make it support

#28

And I have hd 5870m as gpu. It says it support openGl5 with ARB_direct_state_access. Yet i still can not run it :sweat_smile: yuzu starts. When loading screen finishes i see the first screen, then i get ‘your graphic card stopped working’. Then yuzu freezes.

#29

^ Same but using HD6370M. Apparently supports OpenGL4.5 with ARB_direct_state_access.
On Let’s Go Pikachu I see the first controller screen, then i get ‘your graphic card stopped working’. Then yuzu freezes.
What’s more I get this only on LGPE, the other game I have “I am Setsuna” works without freeze and ‘your graphic card stopped working’.
And whats even better yuzu doesn’t freeze if I force it to use Mesa 19.0.3 drivers, but then the graphics are too garbled to do anything since I have no clue how to set it up properly. But I am able to actually go ingame on newest build.
But wait, there’s more. It works ok on Canary 1788 but not really playable since the build is so outdated. Since 1789 - freeze and ‘your graphic card stopped working’. ¯_(ツ)_/¯

#30

yeah, ı have read about it. they started opengl 4.5 bullshit after some version.
I tried mesa but, couldnt work it out yet.
and I tried move in linux too, tried linux mint, then I learned that I can not install proper grachic driver for openGl. I tried mesa in linux too, but it but mesa in linux made my opengl v3.3
now ı am looking for extenal graphic cards for my laptop :)) :((

#31

hey, did you delete your AMD driver before installing Mesa ?

#32

No, I didn’t install it. I did something similar to this thread Force OpenGL3.3 on Intel HD Graphics 3000 (Windows) but forced OpenGL4.5
At least it proves that this GPU is capable of booting PLG without freezing. As to why it stopped working on proprietary drivers ¯_(ツ)_/¯

#33

well, i think, i couldnt make it work for yuzu :frowning: i tried that old opengl32dll and tried some other ones claimed to be for opengl 4.5. in the end bat file doesnt open yuzu, just shows cmd screen for a second.
how did you make it work that way man ?

#34

Idk, I did as in the guide but typed 4.5 instead of 3.3 and didn’t switch opengl32.dll. And to say that it works is an overstatement. Graphics are all garbled and its between 1-2FPS while in 1788 Canary graphics were fine and I had ~20FPS in buildings. So its in no way playable. But it doesn’t freeze.

#35

damn it, 1788 worked on me too. why do they have to change system requirements. ı am so uncomfortable with it. mad about it. i could have been playing this too

#36

do you think we can mix some of .dll’s. then we might get a decent gameplay :stuck_out_tongue:

#37

Honestly, idk. If you manage to mix some dlls let me know :wink: I don’t really have the incentive to try out every possible combination. Especially since the problem is yuzu only. One of the options might be to install Linux but I’m not too fond of it. What bugs me though is that yuzu log shows Opengl as 4.3.13417 while Windows insists its 4.5 I’m not even mad that it doesn’t work. I’m more mad that that it used to work :confused:

#38

Don’t even try yuzu on anything lower than 1070 and ryzen 5 or intel i5s 8th gen+ and 16 gb ram is minimum.

#39

well, ı was mad too. but not anymore, time takes it :)) i dont care anymore. plus ı learned that LGP doesnt have all generations.
i think ı am gonna play pokemon sword on my future computer

#40

RPCS3 tries to use either GL_ARB_direct_state_access and GL_EXT_direct_state_access and also looks for the appropriate functions directly and if found assume the extension is there. This helps older Intel iGPUs. See: https://github.com/RPCS3/rpcs3/tree/master/rpcs3/Emu/RSX/GL most notably in GLHelpers and GLGSRender header and C++ files.