Yuzu freezes when loading roms (error 14)

Issue :
Yuzu freezes with error message “Failed to load ROM (Error 14)!” when loading Pokemon Sword (NSP file). The file works in Ryujinx, but is too slow to be playable. Also tried with two other roms in xci format, same error.

System Information

  • Operating System: Ubuntu 20.04
  • CPU: I7-7700HQ CPU
  • GPU: 1050 Ti - 4GB
  • Yuzu Version (found in title bar): master-182cf7d63
  • Game: Pokemon Sword
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log !
Upload your log file as an attachment by dragging & dropping. yuzu_log.txt (8.0 KB)

System Information for Support

Client Version                                yuzu Development Build master-182cf7d63
Operating System                              Ubuntu 20.04.1 LTS
CPU                                           Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GTX 1050 Ti/PCIe/SSE2
GPU Driver Version                            450.66
Use Async GPU                                 [ ]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Enabling Async GPU emulation is recommended as it can improve the performance of many games.

Your games are corrupt. Redump them from your Nintendo Switch.

But all the games work on Ryujinx, if they were corrupt they wouldn’t work on either, right?

Why don’t you use Yuzu Windows version Pokemon Sword works there, Rujinx is slow and eats a lot off resources and no more Vulkan, Xenoblade 2 works there with Update and DLC’s but I want it on Yuzu to play it, and Yuzu has more games compatibility than Ryujinx, not all the games works in both emulators, and we can chat with developers on this forum, but Ryujinx it doesn’t have a chat group like in hear.