Yuzu Full Screen not working

Hello Community,

The Fullscreen Mode in Yuzu doesnt really work. The Window is really in Fullscreen but my Cursor isnt locked, i can interact with stuff on my my Desktop while a game in running in Fullscreen wich makes most games not really playable.

Ive Yuzu on my Launchbox and tried to do the “-f -g” Standart Command and also change somethin in the AutoHotkey script both methods help other users but not me.

Is there another solution? I really would like to play my Games normal.


Scripte

In order for us to provide better support, we need to see the log generated by yuzu. This guide will walk you through how you can obtain the log file: Getting Log Files - yuzu

Are you using keyboard/mouse for the controller in yuzu? Or just a normal controller? It should only lock your cursor if you’re using keyboard/mouse for the input device in controls page and during gameplay you activate mouse panning (ctrl + f9)

If you’re using a normal controller for yuzu and want to hide your cursor you can enable the setting in the general config page
image
‘hide mouse on inactivity’ but it doesn’t bind your mouse to yuzu it will just hide it on inactivity.

Your mouse being able to be used during gameplay in fullscreen when using a controller is expected. I just provided both example scenarios as I’m not sure what you were using input wise.

Hey Ghost,

Thank you for youre Help! :smiley:

Im using a Xbox One Wireless Controller!
And i have ticked the box “Hide mouse on Inactivity”, my Yuzu is in German and the box and says “Mauszeiger verstecken” wich translates to “Hide Mouse Cursor”. There is nothing with inactivity but it must be the same Box maybe its just the Translation.
But i`ve noticed that when i press F10 and F11 many times randomly my Cursor is really invincible idk what i do.

But my next problem is that every time i press my left analog stick this weird digital Keyboard appears, so i cant run or charge in all of my Games like Super Mario Odyssey. I dont know if this is just window or Yuzu and how do i remove this keyboard?



for the second part you mentioned that is due to you having steam open. It loves to provide you things that ‘help you’ but in many cases like for yuzu or other emulators it can bite you in the butt :sweat: If you don’t need steam open atm it would be ideal to close it in taskbar to avoid that issue. Or you can go to the steam big picture and uncheck the controller support in the config page & there is another page like ‘desktop configuration’ I believe that has something else you can turn off for that keyboard popup or ease of access crap steam tries to offer.

I’m curious as well if using


‘Exclusive Fullscreen’ for Fullscreen mode (in config >> graphics) helps any for your situation with the mouse. If you only have one monitor and use exclusive fullscreen it should stop the ability for the mouse to be able to touch it. As well with steam being closed it should stop it from interfering with the things I mentioned in previous message

Closing Steam completely really worked my cursor is now gone and the keyboard doesn’t appear. I didnt know that Steam was such a problem with Yuzu :open_mouth:

Thank you for youre Help! :smiley:

My Last Problem/ Question is how do i run in games like Super Mario Odyssey? It should we the left analog Stick but Mario is moving in the same speed and also i cant to the dive jump. Its also in Games like The Legend of Zelda: Links Awakening.

The Analog stick is working i can also press it down and Yuzu decects it.

1 Like

See if playing with deadzone or range for the left joystick helps any. Generally for input controls I spin my joysticks in a circle to ‘refresh it’ then set my deadzone/range if it is still a bit off.

1 Like

For Zelda links awakening to sprint you have to unlock the dash ability then you use L/ZL while moving joystick to sprint

Mario odyssey if I rememember correctly you also hold down X/Y while moving joystick to speed him up.

1 Like

Right you were also using an xbox controller. Some people have had some input issue with them when vibration was enabled. If you still get issue after the previously mentioned things. Try disabling vibration in the yuzu controls page
image. Some xbox controllers act weirdly when vibration is enabled. The input dev here has been trying to sort it out.

1 Like

Thank God, turning off the vibration really helped me!
All my Problems are fixed, you are very helpful! :smiley:

1 Like

Glad to hear it! :pray: