Yuzu internal time two hours delayed from my PC time

As title says, my internal time in Yuzu is two hours beyond the actual time on my PC. It’s no big deal, but it’s annoying. Is there a way to fix it? I am using the mainline Yuzu 246.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

there is not much you can do about that for now.

You could set a custom RTC every single time before you launch a game.
Settings > System > Custom RTC. You would have to change the time there, offset by however many hours it is wrong, then restart yuzu, then start the game.

This does not update by itself so you would have to do the same thing the next time before you start a game.

Here’s the log file. I hope you’ll come with something, because it bothers me.
yuzu_log.txt (213.1 KB)

System Information for Support

Client Version                                yuzu 246 HEAD-mainline-636-2034-g57812d3e5
Operating System                              Windows 10 (10.0)
CPU                                           AMD FX(tm)-4320 Quad-Core Processor            
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GTX 750 Ti/PCIe/SSE2
GPU Driver Version                            441.20
Docked Mode                                   [ ]
Use Async GPU                                 [x]
BCAT Backend                                  boxcat
GPU Emulation Accuracy Level                  High

Here’s some issues I found with your log that might help.

  • You have Boxcat (BCAT) enabled. Some games might not work when this is enabled. Please disable and try again if you are experiencing issues with games.

as you were told earlier there is no other solution for now other than what I described.

Sorry but that’s not a solution, that’s workaround and right now I am sick of workarounds. Workarounds kill people. Not gonna say more or I’ll be banned, but seriously, if I am the only one having this issue, I was hoping you’ll find something wrong with my PC. Otherwise, I hope the Yuzu devs will notice and find a solution for future release. All in all, I hope my post will be helpful one way or another.

OK, I’ve found there’s even bigger issue with time then being delayed. The time is not moving in game at all. For example, I’ve sent my Pokémon in Sword to Pokéjobs and even after 12 hours the time showed in Rotomi is still the same no matter what I do. Fixed time, changing time on my PC, nothing works. For Pokémon games this is as big of an issue as the softlocks, which you thankfully solved. Now plese fix this time issue as well, so we can finally enjoy the games to their fullest.