Yuzu performance drops when in fullscreen

Hi guys!

I haven’t been using Yuzu for some time and tried the latest EA version yesterday.

Many games that did not work good before work great now (like Super Mario Odyssey, Mario Kart 8 Deluxe and Diablo 3 CE etc., I’m getting 60 FPS in those games).
But, when I switch the emulator to fullscreen, my framerate drops and the game starts lagging.
The moment I switch it back to windowed it works great.

One thing I’d like to add is the game starts lagging in fullscreen after a few seconds. If I swith to Windowed and then to Fullscreen it works fine again for a few seconds and then starts dropping frames, stuttering and lagging.

I’ve tried the settings in the screenshot attached.

My specs are:

Ryzen 7 3700X
RX 580
16GB RAM
Games are on HDD

I tried EA 1350 and EA 1357 and the current mainline.

Any help would be much appreciated. Let me know if I can provide any further information.

I was not able to upload my log file due to size limit, so here it is: https://anonfiles.com/355661B3pa/yuzu_log_txt

image

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Stupid idea, try adding yuzu as a profile in the Radeon Software, and enable enhanced sync .

1 Like

Well, I love “stupid” ideas! But in this case, it did not work :frowning:

I’ve seen this happen with AMD cards before, the reason is that in fullscreen, the card switches to lower clocks. Besides using something like MSI afterburner to fix the clock speeds, I haven’t found other alternatives.

I just hope this gets fixed or something. No other app or game loses performance if I use it in fullscreen.

I’ll just play windowed for now, since fullscreen drops FPS and input lag is noticeable. Can’t be too sad though, the last time I used Yuzu on the same hardware, I could barely reach 30 fps in most games, other than Link’s Awakening. That game runs at 55-60 fps since it was released.

If someone has any suggestions in the meantime, please let me know.

Can you try enabling anti-lag in the driver features?

Hi there! I tried that, but it did not work.

That said, your suggestion reminded me of the most obvious cause - freesync!

I disabled freesync for Yuzu and fullscreen appears to be working great now!

Thank you so much for your help!

1 Like