Yuzu - Screen flickers while playing, G-Sync issue?

While playing Pokemon Let’s Go Pikachu (which runs perfectly fine, thanks for your work!) I realized that when you enter/during/exit a battle, the screen starts flickering and won’t stop for a while.

I’ve been reading that it may have something to do with G-sync, so I turned it off and the flickering went away, still, any chance this could be fixed in future updates?

Or is there already any work around to avoid to have to turn g-sync off everytime I run yuzu, by any chance?

1 Like

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Unfortunately we don’t have a G-Sync panel to test. I’ll ask anyway.

Thanks for your fast reply!
I tried playing again today and I realized it flickers not only when I enter/during/exit combat, but even if I’m watching a youtube video while playing, at any point of the game.
Maybe it has something to do with the GPU load…? No clue.
This is the log btw.

yuzu_log.txt (1.8 MB)

System Information for Support

OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2060 SUPER/PCIe/SSE2
OpenGL Version                                4.6.0
GPU Driver Version                            441.87
Enable CPU JIT                                null
Docked Mode                                   [ ]
RNG Seed                                      [ ]
Use Accurate GPU Emulation                    [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Video playback can interfere, I get some problems if I do the same with my 270X. I guess the GPU doesn’t want to be on decoding and gaming at the same time?

I guess, but to me it happens only when g-sync is on, if I turn it off I get no flickering at all, even while I have a video running or in battle.
Again, it’s not a major issue, the game runs perfectly fine so far, it’s just a bit of a pain in the ass to always have to switch it on/off before/after playing!

I have the same issue… if I turn off G-sync, the flickering disappear.

i fix it just change GSync for window mode and full screen and it stop flickering… if it on full screen only it flickering… https://www.if-koubou.com/img/images_4/how-to-enable-optimize-and-tweak-nvidia-g-sync_2.png

I always had it on window mode & fullscreen, and it still flickers, so nope, that doesn’t fix it.

Hello,

I can relate with you guys, I have the same issue. I get monitor brightness flickering when using retroarch. It happens when I use the Mupen64plus emulator. At first I thought it was the crt scanlines shaders causing it, I was wrong.

The weird thing is, once the flicker starts, even after closing retrioarch the brightness flicker persists on the desktop and even carries on happening if I open the nvidia pendulum demo. I don’t get this (or haven’t noticed it) in any pc games I play. Just when playing emulators in retroarch.

Just like you guys, i eventually figured out that gsync was the cause. There is actually a setting in retroarch to enable/disable gsync, I tried disabling gsync inside retroarch but it didn’t help, the nvidia gsync logo still appears on screen (to show it is enabled). If I disable gsync in the nvidia control panel when the flickering is happening the flickering instantly stops.

I now turn off gsync in the nvidia control panel before running retroarch, and renable it afterwards, this way I don’t get any flickering.

Thanks for creating this thread, I thought my monitor was going bad. Seems like it is not only this particular monitor that is affected.

This brightness flicker I see looks like this : (Notice the dimming on the left side of the video, this is not my video, just an example) : G-sync pendulum demo flicker for AG352UCG - YouTube

Monitor - 1 x Acer xb271hu (144hz gsync) connected to a 2080ti (displayport), nvidia driver 472.12. I am using gsync fullscreen only (but also tested fullscreen + windowed to no avail).