Yuzu won't render graphics

#1

So I tried to boot Cave story using latest Canary and was greeted with this (audio is normal):

I know for a fact that it used to work in early December builds as I was able go go ingame without any problems and it ran perfectly.
Meanwhile in Ryuujinx:

No problems at all, so it’s not my PC or bad rom dump. Anything I can do in settings to make it show something on Yuzu? Or is it just Yuzu being bad with AMD GPUs/some kind of regression in newest builds?
yuzu_log.txt (60.0 KB)
Log cropped because it repeated the same thing.

#2

System Information for Support

Enable CPU JIT                                null
Enable Hardware Renderer                      null
Enable Hardware Shader                        null
Hardware Shader, Accurate Multiplication      null
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             null
Enable Vsync                                  null
LLE Audio Emulation Enabled                   null
Use GDB Stub                                  null
System Region                                 null
OpenGL Version                                4.3.1
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon HD 6300M Series

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

Based on that picture and your GPU, I would assume that you’re hitting a point where GPU manufacturers try to fabricate GPU extensions for compatibility. Your GPU only supports OpenGL up to 4.3, while the extension that we use is core in OpenGL 4.5. The reason why Ryujinx works for you is because they do not use this extension, and Yuzu uses it for mostly larger games, like Super Mario Odyssey.

Your possible options: either update to the latest drivers (Beta if possible), or get a newer GPU (in your case - a new laptop).

1 Like
#4

Ohhh, I see. I remember the requirements in December being OpenGL 4.3. That’d explain why it used to work. Thank you for an answer.

#5

Once again thank you for your response. I updated to the Beta drivers and it works:


Perhaps it won’t ever be the demon of speed but at least it shows something. That is until Yuzu decides to increase requirements again xD