Zelda: A link between worlds Hyrule Castle Freeze

Issue:
Enter a description of your issue here, in full detail.

System Information

  • Operating System: 64 bit
  • CPU: Intel® Core™ i5-8250U CPU @ 1.60GHz
  • GPU: Intel® UHD Graphics 620
  • Citra Version (found in title bar): Citra Canary 1755
  • Game: Zelda: A link between worlds
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (38.3 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I can still move and swing my sword as you can hear it. But the whole screen either freezes on impa moving or link in the doors.

System Information for Support

Client Version                                Canary 1755 HEAD-41dc0b7
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 620
GPU Driver Version                            24.20.100.6286
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 3
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

GPU Driver Version: Build 24.20.100.6286

This driver is outdated, you need to update.

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed that download and install igfx_win10_100.8190.exe from: https://downloadcenter.intel.com/download/29557/Intel-Graphics-Windows-10-DCH-Drivers?product=124967
direct link: https://downloadmirror.intel.com/29557/eng/igfx_win10_100.8190.exe

Also do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder(if it’s there)
  3. Emulation->Configure... then click on Graphics on the left
  4. Turn on Disk Shader Cache
  5. Click on the Advanced tab and enable Hardware Shader

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.
Keep Accurate Multiplication turned on.

Utility_DumpTextures: true

You should probably turn off Texture Dumping and delete the dump folder (file -> open citra folder), you probably have a lot of images there right now :stuck_out_tongue:

1 Like

Thanks for your help :slight_smile: I will see if it works after it downloads.
You were right about the Photos I had 44, 540 that got deleted :astonished:
Also I have been trying to update my driver for a while and haven’t been able to find how to do it a big thank you to you and your support.

What step are you stuck on? Show some screenshots so I can see.

No help needed. All works fine! Thank you again!

1 Like