Zelda Ocarina Consistent Freezing

Issue:
Using Henriko’s Texture pack v.1.3.3 for Ocarina of Time 3D and a February version of Citra (Canary 1939). I’m getting consistent freezing where the image is frozen and music continues playing. I’ve tried disabling Accurate Multiplication, Hardware Shaders, and XBR Filtering to no avail. They show something about not being able to open “Save01.bin” and “Save02.bin” but maybe that’s a normal entry for some reason. I should also say I also used Canary 1990 and the same thing happens…

System Information

  • Operating System: Win 10 v.2004
  • CPU: Intel i7 10750H
  • GPU: NVIDIA GeForce RTX 2070
  • Citra Version (found in title bar): 1939
  • Game: The Legend of Zelda - Ocarina of Time 3D

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I’ve removed the log text posts as this makes the topic completely unreadable. Please follow the steps in the log file guide to attach the log file to you post. Please don’t upload the contents of the log file in the chat box. It makes it hard to read and, as mentioned earlier, clutters up the support topic.

citra_log.txt (27.9 KB)

System Information for Support

Client Version                                Canary 1939 HEAD-8bb1c49
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             NVIDIA GeForce RTX 2070/PCIe/SSE2
GPU Driver Version                            471.11
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Does the same freeze occur without the use of Custom Textures?

Yes, I’ve tried Citra v1990 freshly downloaded with default settings and no custom textures

Please upload a log file without the use of custom textures.

citra_log.txt (14.5 KB)

System Information for Support

Client Version                                Canary 1990 HEAD-2eb3e59
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             NVIDIA GeForce RTX 2070/PCIe/SSE2
GPU Driver Version                            471.11
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Could you create a new portable build to rule out any other issues with your current Citra installation?

Go to Download Citra - Citra and select Manual download. Then under Nightly Build, click on your operating system’s icon to the right of the latest build available to download the build.
Extract it (.7z can be extracted using Winrar or 7zip) (.tar.gz can be extracted natively on MacOS) and put it where ever you wish. Inside the extracted mingw folder, create a folder called user. This Citra should now store all of its config, save files and such inside of this user folder.
Check to make sure that this user folder is in the same folder that contains citra-qt(.exe)
Now run the citra-qt executable found inside of the mingw folder and run your game.

Welcome back @SleepingSnake

I have my existing Citra instances (one is 1939 and one is 1990) both set up with “user” folders alongside the main executable so that my backups of my emulators and roms are easier to maintain on my external drives.

While waiting for your reply, I actually ported everything over to another PC of mine to see if this was driver or hardware issue with my main gaming PC and Citra freezes on my other PC as well.

Is there some other next steps we could take since my Citra instances are already disparate, each with their own “user” folder…?

Ah okay. Most users tend to use our installer so this is something I tell users to do to rule out issues with regular installations. If you’ve already gone through the steps yourself, there’s obviously no need to do so again.

At this point, we’ve ruled out Citra, drivers, hardware, user added files and settings. That basically means that all that’s left is the dump. Usually the log file gives some sort of indication about this, but that didn’t happen as far as I could tell. Hence why I tried ruling out everything else first.

You’ll need to redump your game. Please refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.

Oh shucks. I own the game legitimately (in my hand)…but my 3DS broke 2 years back, so I’m using roms from ahem various sites. I’ve tried various roms in both *.3ds and *.cia formats and these were from different sites but all with this same freezing. Is there a “best practices” or something else like that which I should be adhering to, such as “always use X format”, “always have Citra in the root of your drive”, or “never put dashes in the directory path to the rom file”…anything like that? I actually figured out that Henriko’s texture pack didn’t like “-” in the path because ReShade wouldn’t load until I renamed the directory path…

Any advice you can think of that I should be doing on my end? I’m really determined to nail down what’s going on here…