Zelda triforce heroes screen freeze but game works

Issue:
Hey, so my issue is that when i play triforce heroes everything works fine until i enter a dungeon solo or multiplayer 3/4 seconds after the dungeon loaded my screen freezes. From the sound i can tell that the game is still playing as i can hear the sword swing effect. This means my problem is just the game display which freezes and is stuck frozen. So far i have tried to disable hardware shader, i’ve tried enabling accurate multiplication and I’ve also updated my graphic drivers. All other games seem to run absolutely fine except triforce heroes.

System Information

  • Operating System: windows 10 home 64bit
  • CPU: i5 8250U
  • GPU: UHD graphics 620
  • Citra Version (found in title bar): canary 1427/1361
  • Game: The legend of zelda triforce heroes
  • Screenshot of Issue (include the full Citra window including titlebar):

citra_log.txt (83.0 KB)

System Information for Support

Client Version                                Canary 1427 HEAD-d158e08
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) UHD Graphics 620
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Already tried this option sorry

Did you disable ‘Enable Hardware Shader’ before launching the game? doing after won’t help.

yes i did try that doesnt work, unfortunately

I think the current citra citra version have bug that make some game freeze like that on intel gpu, i got intel hd 4600 and have same problem with kingdom hearts 3D, best is to get a cheap use gt 740 and above since nvidia work best with open gl emulator i think, i posted my problem here the other day:rofl:

But I’m on a laptop ?

Maybe try installing linux along with window